Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000067Active Directory IntegrationMultisitepublic2012-08-22 19:142012-08-22 19:17
Reporterarencambre 
Assigned Tocst 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusassignedResolutionopen 
PlatformOSOS Version
Product Version1.1.3 
Target VersionFixed in Version 
Summary0000067: Settings for base blog not being stored in wp_options
DescriptionOn a multisite, the base blog's settings are stored in tables prefixed with wp_. This is as opposed to wp_x_, which is the prefix for all other blogs.

The base blog's Active Directory Integration settings are not being stored in wp_options. It's not clear to me where they are in fact being stored. I know this because the value for the "Group(s)" settings under "Authorize by group membership" at https://servername.com/wp-admin/tools.php?page=active-directory-integration [^] does NOT match the value for AD_Integration_authorization_group inside wp_options. Also, changing AD_* options under wp_options has no effect on the values shown at https://servername.com/wp-admin/tools.php?page=active-directory-integration. [^]

All settings for the base blog should be stored in wp_options, not in some apparently random sub-blog's settings.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000091)
arencambre (reporter)
2012-08-22 19:17

OK, this is weird, but looks like the options are being stored in wp_sitemeta. Should an older version of the settings be stored in wp_options?

- Issue History
Date Modified Username Field Change
2012-08-22 19:14 arencambre New Issue
2012-08-22 19:14 arencambre Status new => assigned
2012-08-22 19:14 arencambre Assigned To => cst
2012-08-22 19:17 arencambre Note Added: 0000091


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker